Fehler beim Steamlogin

  • Pluginversion: 3.0.0

    WBB: 5.2.7

    Plugin: Steam Authentifizierung OpenID Integration (WSC)


    Hallo, habe auf meinem Frisch installiertem Forum den Steamlogin installiert und jetzt wenn man sich über Steam anmelden möchte kommt immer folgende Fehlermeldung:


    System Information

    • PHP Version:

      7.4.9

    • WoltLab Suite Core:

      5.2.7

    • Peak Memory Usage:

      1.517/128 MiB

    • Request URI:

      /forum/index.php?steam-auth/&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.mode=id_res&openid.op_endpoint=https%3A%2F%2Fsteamcommunity.com%2Fopenid%2Flogin&openid.claimed_id=https%3A%2F%2Fsteamcommunity.com%2Fopenid%2Fid%2F76561198037824240&openid.identity=https%3A%2F%2Fsteamcommunity.com%2Fopenid%2Fid%2F76561198037824240&openid.return_to=http%3A%2F%2F62.141.45.87%2Fforum%2Findex.php%3Fsteam-auth%2F&openid.response_nonce=2020-08-29T10%3A17%3A28Zsgc%2FNDCu5MvkdqiboNHp%2FNMvLSw%3D&openid.assoc_handle=1234567890&openid.signed=signed%2Cop_endpoint%2Cclaimed_id%2Cidentity%2Creturn_to%2Cresponse_nonce%2Cassoc_handle&openid.sig=Za%2BmbIjewQz7X0OJXPL43XhSTXA%3D

    • Referrer:
    • User Agent:

      Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36

    Error

    • Error Type:

      wcf\system\exception\ErrorException

    • Error Message:

      Function get_magic_quotes_gpc() is deprecated

    • File:

      */lib/system/WCF.class.php (341)

    • Stack Trace:
      • #0 */lib/data/steamSignIn/SteamSignIn.class.php (73):
      • wcf\system\WCF::handleError()
      • #1 */lib/page/SteamAuthPage.class.php (96):
      • wcf\data\steamSignIn\SteamSignIn::validate()
      • #2 */lib/page/AbstractPage.class.php (294):
      • wcf\page\SteamAuthPage->assignVariables()
      • #3 */lib/page/AbstractPage.class.php (114):
      • wcf\page\AbstractPage->show()
      • #4 */lib/system/request/Request.class.php (83):
      • wcf\page\AbstractPage->__run()
      • #5 */lib/system/request/RequestHandler.class.php (107):
      • wcf\system\request\Request->execute()
      • #6 */index.php (9):
      • wcf\system\request\RequestHandler->handle()


    Kann mir jemand dabei helfen?


    Danke :)

  • Gleichen Fehler haben wir seit Wochen auch... Vom Entwickler bisher keine Reaktion - lt. seinem Profil war er hier das letzte Mal am 10.08. aktiv.

    Tritt der Fehler bei dir auch nur mit Firefox und Chrome auf? Mit Microsoft Edge funktioniert es komischerweise bei uns..

  • Kleine INfo, der Fehler ist nicht mehr da. Woran es lag kann ich mir nicht erklären. Bei einer anderen Installation auf einem anderen Server hat es geklappt. Der die einzigen unterscheide waren der Hoster und das Apache2 nicht vorinstalliert war.

    Die vorgehensweise bei der Installation war identisch.


    Grüße

  • Kleine INfo, der Fehler ist nicht mehr da. Woran es lag kann ich mir nicht erklären. Bei einer anderen Installation auf einem anderen Server hat es geklappt. Der die einzigen unterscheide waren der Hoster und das Apache2 nicht vorinstalliert war.

    Die vorgehensweise bei der Installation war identisch.


    Grüße

    Hallo.

    Rein aus neugier mal die Frage:

    Nutzt du jetzt immer noch die gleiche PHP-Version oder eine ältere?